Problem with Billion 2073N and 7800N

Discussion for models not listed
Post Reply
Posts: 2
Joined: Mon Jul 02, 2012 6:48 pm

Problem with Billion 2073N and 7800N

Post by moey187 » Sun Dec 30, 2012 12:55 pm

I have a Billion P106N setup which has been working flawlessly with my 7800N for a year and a half and now suddenly the internet connection speed has decreased considerably on my 2073N device. I was initially having around 6Mbps download speed and now am having around 2Mbps (Slow I know). Has the product just got faulty or is there something I have to look out for. This is my setup:

I live in a 3 story house. The Billion P106N comes with the plug in wall ethernet (Bipac 2073 R2) and the plug in wall access point receiver (Bipac 2073N). I have the Bipac 2073 R2 connected directly to my router (Billion 7800N) on the middle floor and my Bipac 2073N connected wireless to all my devices upstairs.

The internet downstairs connects fine and the speed is fine as it doesn't use the 2073N, however my wireless and LAN speed upstairs have gone down considerably, if anyone has any ideas please let me know what is going on. I have tried resetting to factory default settings and everything!

I have these stats for the remote device in my setup (from the 2073N web settings page):
Transfer rate: 65Mbps and Receive rate: 10Mbps.

Something tells me that the receive rate is too low, however I don't use streaming just the wireless connection.

I will appreciate someones help. Thanks.

Posts: 5205
Joined: Tue Jul 19, 2011 4:30 pm

Re: Problem with Billion 2073N and 7800N

Post by billion_fan » Fri Jan 11, 2013 12:20 pm

Have you tried to plug the Bipac 2073N to a different socket?? Also make sure you are not using any extension cables as this will degrade the speeds

Post Reply