8900AX-2400 as a WiFi AP

Discussions for BiPAC 8900 series: 8900AX-1600, 8900AX-2400, 8900X
billion_fan
Posts: 5211
Joined: Tue Jul 19, 2011 4:30 pm

Re: 8900AX-2400 as a WiFi AP

Post by billion_fan » Tue Jun 16, 2020 3:49 pm

jez_uk1 wrote:
Tue Jun 16, 2020 3:33 pm
billion_fan wrote:
Tue Jun 16, 2020 3:25 pm
don't forget to try swapping the dlink and billion around (so like before and see how it goes)
Oh, they have both always been in the same place. The 8900AX-2400 is sitting next to the 8900X R3, it just got repurposed to AP mode only.
OK anything funny listed within the system log on the 8900ax-2400 when the issue occurs??

jez_uk1
Posts: 30
Joined: Tue Aug 16, 2011 7:50 pm

Re: 8900AX-2400 as a WiFi AP

Post by jez_uk1 » Tue Jun 16, 2020 3:58 pm

billion_fan wrote:
Tue Jun 16, 2020 3:49 pm
jez_uk1 wrote:
Tue Jun 16, 2020 3:33 pm
billion_fan wrote:
Tue Jun 16, 2020 3:25 pm
don't forget to try swapping the dlink and billion around (so like before and see how it goes)
Oh, they have both always been in the same place. The 8900AX-2400 is sitting next to the 8900X R3, it just got repurposed to AP mode only.
OK anything funny listed within the system log on the 8900ax-2400 when the issue occurs??
The only thing I've noticed unusual is this message that gets pushed to syslog when a device switches from Billion to DLink (wlan2 is the Billion, wlan1 is the DLink)

Code: Select all

Jun 13 04:32:11 wlan2 kernel: br0: received packet on wl0 with  own address as source address
Jun 13 04:52:57 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 2.4G:Association Success:STA C0:EE:FB:DF:50:0F
Jun 13 04:52:57 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 2.4G:4-way handshake start:STA c0:ee:fb:df:50:0f
Another one later on:

Code: Select all

Jun 13 10:35:14 wlan2 kernel: br0: received packet on wl0 with  own address as source address
Jun 13 10:35:26 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 5G:Association Success:STA C0:EE:FB:DF:50:0F
Jun 13 10:35:26 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 5G:4-way handshake start:STA c0:ee:fb:df:50:0f

billion_fan
Posts: 5211
Joined: Tue Jul 19, 2011 4:30 pm

Re: 8900AX-2400 as a WiFi AP

Post by billion_fan » Tue Jun 16, 2020 4:04 pm

jez_uk1 wrote:
Tue Jun 16, 2020 3:58 pm
billion_fan wrote:
Tue Jun 16, 2020 3:49 pm
jez_uk1 wrote:
Tue Jun 16, 2020 3:33 pm


Oh, they have both always been in the same place. The 8900AX-2400 is sitting next to the 8900X R3, it just got repurposed to AP mode only.
OK anything funny listed within the system log on the 8900ax-2400 when the issue occurs??
The only thing I've noticed unusual is this message that gets pushed to syslog when a device switches from Billion to DLink (wlan2 is the Billion, wlan1 is the DLink)

Code: Select all

Jun 13 04:32:11 wlan2 kernel: br0: received packet on wl0 with  own address as source address
Jun 13 04:52:57 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 2.4G:Association Success:STA C0:EE:FB:DF:50:0F
Jun 13 04:52:57 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 2.4G:4-way handshake start:STA c0:ee:fb:df:50:0f
Another one later on:

Code: Select all

Jun 13 10:35:14 wlan2 kernel: br0: received packet on wl0 with  own address as source address
Jun 13 10:35:26 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 5G:Association Success:STA C0:EE:FB:DF:50:0F
Jun 13 10:35:26 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 5G:4-way handshake start:STA c0:ee:fb:df:50:0f
Nothing abnormal there, I've seen 'received packet on wl0 with own address as source address' before it shouldn't cause any issues

jez_uk1
Posts: 30
Joined: Tue Aug 16, 2011 7:50 pm

Re: 8900AX-2400 as a WiFi AP

Post by jez_uk1 » Tue Jun 16, 2020 4:06 pm

I've set both the DLink and Billion to auto channel selection and they have changed, so I'll see if for any reason this solves the problem. Attached image of the phone has hopped to the Billion no troubles, it's just very random if sometimes I get the wifi not connected error in Android. You can see the Mac address at the top confirms it's connected to the 8900AX-2400.
You do not have the required permissions to view the files attached to this post.

jez_uk1
Posts: 30
Joined: Tue Aug 16, 2011 7:50 pm

Re: 8900AX-2400 as a WiFi AP

Post by jez_uk1 » Tue Jun 16, 2020 4:11 pm

billion_fan wrote:
Tue Jun 16, 2020 4:04 pm
jez_uk1 wrote:
Tue Jun 16, 2020 3:58 pm
billion_fan wrote:
Tue Jun 16, 2020 3:49 pm


OK anything funny listed within the system log on the 8900ax-2400 when the issue occurs??
The only thing I've noticed unusual is this message that gets pushed to syslog when a device switches from Billion to DLink (wlan2 is the Billion, wlan1 is the DLink)

Code: Select all

Jun 13 04:32:11 wlan2 kernel: br0: received packet on wl0 with  own address as source address
Jun 13 04:52:57 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 2.4G:Association Success:STA C0:EE:FB:DF:50:0F
Jun 13 04:52:57 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 2.4G:4-way handshake start:STA c0:ee:fb:df:50:0f
Another one later on:

Code: Select all

Jun 13 10:35:14 wlan2 kernel: br0: received packet on wl0 with  own address as source address
Jun 13 10:35:26 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 5G:Association Success:STA C0:EE:FB:DF:50:0F
Jun 13 10:35:26 wlan1  [9C:D6:43:29:1B:20][192.168.1.253][0] [Wireless] 5G:4-way handshake start:STA c0:ee:fb:df:50:0f
Nothing abnormal there, I've seen 'received packet on wl0 with own address as source address' before it shouldn't cause any issues
Perfect, yea I didn't suspect that was any trouble, nothing much else. I'll keep an eye, if it happens again I'll record the time and check the logs.

jez_uk1
Posts: 30
Joined: Tue Aug 16, 2011 7:50 pm

Re: 8900AX-2400 as a WiFi AP

Post by jez_uk1 » Thu Jun 18, 2020 9:26 am

Switching the Billion to 5Ghz auto frequency selection appears to have solved the problem, I haven't had the dreaded exclamation mark for a few days now. Not entirely sure why, they were on non-overlapping channels before, albeit manually selected. Either way, fingers crossed! :)

Kidspeed101
Posts: 3
Joined: Sun Nov 29, 2020 12:52 pm

Re: 8900AX-2400 as a WiFi AP

Post by Kidspeed101 » Thu Jan 21, 2021 11:24 am

Hi @jez_uk1

Do you have any config details or guide on how you configure this as a WiFi AP?

Been going around in circles for weeks trying to figure out the configs.

Thanks for any help :-)

Post Reply