Zeroconf/Bonjour only works on my non-Billion routers?

Discussions for BiPAC 7300 series: 7300, 7300G, 7300N..etc
Post Reply
QuackingPlums
Posts: 3
Joined: Thu Feb 21, 2013 7:45 am
Location: UK

Zeroconf/Bonjour only works on my non-Billion routers?

Post by QuackingPlums » Thu Feb 21, 2013 8:16 am

The people who built my home saw fit to use wifi-blocking materials in all my walls, such that I need to have two wifi access points in order to get coverage all over the house. I've discovered however that Bonjour/zeroconf discovery only works if a wireless device connects to my *other* AP - i.e. NOT the Billion one!

My main wifi router downstairs is a Billion 7300N, which is connected to my ADSL line. I also have a Buffalo AirStation AP upstairs, which is connected back to the Billion via homeplugs.
There is a 16-port switch connected to the 7300N and all hard-wired machines and devices connect through this. The Buffalo is only used for wifi devices - note that this is NOT using WDS.
Wireless devices connect to whichever AP is in range, depending on where in the house I am using them. I can browse the web, stream across devices, etc from any machine or device around the house, but the Bonjour/zeroconf thing has me stumped.

Example; I have a RaspberryPi computer hard wired to one of my 16 Ethernet ports and it has lighttpd installed to serve up some simple web pages internally within my network. The Pi is setup to use DHCP and has a Bonjour/zeroconf name of "raspberrypi.local". If I connect a smartphone to the Billion AP then raspberrypi.local will not resolve no matter how long I wait. If I connect to the Buffalo AP then it resolves right away. Hard wired devices can always see the Pi.

Anybody know why this should be? Is there some wireless security setting on the 7300N that is preventing Bonjour/zeroconf discovery?

billion_fan
Posts: 5203
Joined: Tue Jul 19, 2011 4:30 pm

Re: Zeroconf/Bonjour only works on my non-Billion routers?

Post by billion_fan » Thu Feb 21, 2013 2:26 pm

Try using the fixed host option to set a static IP to RaspberryPi. Once done restart RaspberryPi to obtain a new IP address and test again.

Also make sure you disbale WMM

QuackingPlums
Posts: 3
Joined: Thu Feb 21, 2013 7:45 am
Location: UK

Re: Zeroconf/Bonjour only works on my non-Billion routers?

Post by QuackingPlums » Fri Feb 22, 2013 10:24 am

Thanks for the suggestion, but that will just bypass zeroconf though, won't it?

I want to solve the problem of getting zeroconf working through the Billion - the Pi was just an example of this happening. I have various other devices that suffer from the same thing and I don't want to have to setup fixed hosts for all of them. :cry:

billion_fan
Posts: 5203
Joined: Tue Jul 19, 2011 4:30 pm

Re: Zeroconf/Bonjour only works on my non-Billion routers?

Post by billion_fan » Fri Feb 22, 2013 10:40 am

QuackingPlums wrote:Thanks for the suggestion, but that will just bypass zeroconf though, won't it?

I want to solve the problem of getting zeroconf working through the Billion - the Pi was just an example of this happening. I have various other devices that suffer from the same thing and I don't want to have to setup fixed hosts for all of them. :cry:
What firmware verison are you running??

QuackingPlums
Posts: 3
Joined: Thu Feb 21, 2013 7:45 am
Location: UK

Re: Zeroconf/Bonjour only works on my non-Billion routers?

Post by QuackingPlums » Fri Feb 22, 2013 10:48 am

billion_fan wrote:What firmware verison are you running??
1.07.dj7

billion_fan
Posts: 5203
Joined: Tue Jul 19, 2011 4:30 pm

Re: Zeroconf/Bonjour only works on my non-Billion routers?

Post by billion_fan » Fri Feb 22, 2013 10:59 am

QuackingPlums wrote:
billion_fan wrote:What firmware verison are you running??
1.07.dj7
Try 1.08a.dj4

Attached, don't forget you will need to reset back to factory default settings after the firmware upgrade, and manually reconfigure the device again.
You do not have the required permissions to view the files attached to this post.

Post Reply